Using ConTEXT with ASReml|

ConTEXT is a popular choice among ASReml users on the Windows® platform. It is a freeware text
editor that lets you associate file extensions with a program so that you can open a program and run it
on afile.

You can use ConTEXT as a file editor to import or write ASReml command files, then run the ASReml
program directly within ConTEXT and display the results.

€ ConTEXT - [C\Users\jane\Desktop\ASReml Projectsh\barley.as] - O X
C File Edit View Format Project Tools Options Window Help -8 %
- flds s S8 8 B B B Tefiles ©
5] ReadMetst |5 Historptat M baley.ss
2 ' ' ' ' o300, 35 ' ' ' ' ' ' ' ' '
File Panel * Lo b e b b bvvve b bevrc b brvve bvvran bvvre brvee b berre e b
File Explorer | IRENAME !ARG 1 2 3 ~
D:AConTEXTAConTEXT !DOPART §1

e i "
Name Slate Z-_lall example
Backup ~ Rep &
Lo RowBlk 30
Highlighters o -
ColBlk 30
Language -
row 10
Template . _—
column 15
[25] ConExec.exe variety 25
[ CanTEXT .chm yield
\G\ ConTEXT.exe barley.asd !skip 1
|=| History.tat
e N - -
% Notepad exe IPART 1 # RR1*AR]1
MNotepadReplace. bat ¥ o~ mu Var
NotepadJnReplace bat residual arlv(column) .arl(row)
| ReadMe.txt A PREDICT wvar !TWOSTAGEWEIGHTS W
< > < >
= Executing: D: \ConTEXT\ConTEXT\ConExec.exe "C:\Program Files\ASReml4\bin\ASReml.exe” barley.as™ -

ASReml 4.1 [28 Dec 2014] mv [29 Mov 2017] 24 Aug 2018 09:07:18
Registered to: vsn
Serial Mumber: 402051998, expiry: 31-mar-2019
ASReml 4.1 [28 Dec 2014] Slate Hall example
Buid mv [29 Nov 2017] &4 bit Windows x64

x Output Congole

Lr 29, Col 23 Inzert Sel Mormal Los File: size: 592

Copying the Example Data Files

As part of the setup process you will need to run an analysis on one of the example data files bundled
with ASReml to ensure that your ConTEXT configuration is working correctly.

The folder containing the ASReml| example data files is read only, so you will need to copy this folder
and paste it to a new location where you have write access, such as your desktop or D: drive.

The following instructions assume that you have pre-installed ASReml to the default location, which is
C:\Program Files\ASReml\.

Navigate to C:\Program Files\ASRemlI\Examples.

Right-click the Functional folder and select Copy.

Now go to your desktop, right-click and Paste the folder there.

Rename the folder ASReml Projects. This is just for convenience

Note: You can copy the Functional folder to a location other than desktop and name it anything
you like. The instructions that follow will use desktop as the file location and ASReml Projects as
the folder name.
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Downloading ConTEXT

e Download ConTEXT from http://www.contexteditor.org/

¢ On the Downloads page select the newest version (the top option).

Downloads Information

v0.98.6 .

Download Size (1.57 Mb) | I
A

v0.98.6 - Portable Version \0/

Download Size (2.06 Mb)

o After downloading ConTEXT, double-click the downloaded file and follow the instructions to install it.

Configuring ConTEXT to run ASReml

e Start ConTEXT then from the menu select Options>Environment Options.

C ConTEXT

File View Project Tn:n:nlsletin:nns Window Help
éﬁ; Environment Opticns... |[ . Y

Fi Code Templates..,
%, Stay On Top I

O Export Registry Settings...
E j T
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http://www.contexteditor.org/

e On the General tab select Automatically update changed files.

Environment Options
General Editor  Colors  Execute Keps  Associations  Miscellaneous

Backup file on zave
() Uze curent directony
(®) Backup directany: D:AConTEXTAConTEXTAB ackup
[ Replace original extension with BAE,

Bemember editing pozsitions

Remember lazt directony used

Remember Find/Replace dialog ophions

[] Detect file changes by other application

Automatically update changed filez

[ Show find/replace information dialog

[ ] 5how user exec completion dialog

e Select the Execute Keys tab.

Environment Options

Gemeral Editor  Colors Execute Keys  Gesocigtion:  Miscellaneous

e Click Add then type your required extensions and click OK.
(The most common file extensions are as, asd, csv, dat, txt.)

Gemeral Editor  Colors  Ewecute Keys  Aszsocigtion:  Miscellaneous

User enec keys Execute:
v |
""" F3 Skart in:
..... F10
- F11
‘e F12 Parameters:
i o
Hint;
Extension edit * fiore execution

Enter extensions separated with commas:

|as, asd, csv, dat, txt |

Cancel

| Pauze after execution
Add E dit Delete [T 1dle pricrity

e

Optional parameters:

Page 3 of 13



e Under User exec keys click F9. This will enable you to run ASReml command files using the
keyboard F9 key

e Fill in the fields as follows:

Environment Opticns )4

Gemeral Editor  Colors  EwecuteKews  Azsocistion:  Miscellaneous

User exec keys Execute:

o aodeooy, dat, bt | |
ES_ Skart i
L | |
..... Fi1

L F12 Barameters: I—I

1. Inthe Execute field click [==! and navigate to the ASReml program.
By default this will be C:\Program Files\ASReml\bin. Select the file called asreml .exe.

2. Inthe Start in field type %p.
3. Inthe Parameters field type %f.
4. In the Hint field type ASReml.

5. (Optional) Select the checkboxes Capture console output and Scroll console to the last line.

Environment Options >

Gemeral Editor  Colors  Ewecute Keys  Aszsocigtion:  Miscellaneous

User exec keps Execute:
w - &g, asd, cev, dat, bt | C:4Program Files\ASRemi\bintS Reml ex| |

:;?D e Skart in;
1 . <P J
—

- F12 Parameters:
i o M armal w
Hint: |45 Reml @
Save: Current file before execution

[] Usze short D05 names
LCapture congole output 6}
Compiler output parzer rule: '
| E

Scroll congole to the last line

Pauze after execution

e At the bottom of the window click OK.
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Testing your Configuration

You should now test your configuration by running an analysis on one of the ASReml example data
sets.

e From the menu select File>Open then navigate to the ASReml Projects folder on your

desktop.

C ConTEXT

File | View Project Tools Opticns Window Help
] New CeeN B [Py [T )
||13 Open.. Ctrl+ O ”

by Save Ctrl+5
Save Az..  Shift+Ctrl+5

e Select barley.as then click Open.

€ Open >
™ » ThisPC » Desktop » ASReml Projects v O Search ASReml Projects o
Organise - Mew folder =z » [H 0
~ - & ~
s Quick access [] MName Date modified Type
barley.apj 26/02/2015 12:25 ASRemlAPL2
[ Desktop 1 SY-2P]
) . ' barley.as 17/02/2015 16:50 ASReml progr:
@ OneDrive - V3N International | Bl Garley.asd 17/02/201516:50  ASReml data fi
Attachments M bsiremod.as 17/02/2015 16:50 ASReml progr:
Camtasia Studio [ coopfmt 17/02/2015 16:50 FMT File
Docs_dont throw away ' coopmf.as 17/02/2015 16:50 ASReml progrz
Documents ' Coopu.as 17/02/2015 16:50 ASReml progrz
Help and Manual g grass.ap) 26/02/2015 12:25 ASRemlAP)L2 v
Helnfndbdanial Praiects il 2
File name: | barley.as v|  Textfiles a7 v|
| Open | | Cancel |
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This loads the file into the ConTEXT console.

€ ConTEXT - [C:\Users\janc\Desktop!ASReml Projects\barley.as] - O X
‘€ File Edit View Format Project Tools Options Window Help -8 %
PWHAed SR sDOve L L% HN &S E S Ak ©
’ barley. as
: 5 0 . . . . . . . . B0 . B85
[A=bend ® I||||I||||-I||||I||||I|\|\I\|||I||||I||||I||||I||||I||||I|||\I\|||I||||I||||I||||I||||I
'RENAME ARG 1 2 2 ~
IDOPART $1
B ] El} A # Barly trial with 25 varieties in € replicates laid out as
’barle}l.as # Balanced incomplete block design.
Slate Hall example
Rep €
RowBlk 30
ColBlk 30
row 10

column 13

wvariety 25

yield
barley.asd !skip 1

'PART 1 # RR1*RRI1

¥y ~ mu var

residual arlv(column) .arl(row)
PREDICT wvar !TWOSTAGEWEIGHTS

IPART 2 # RR1*ARl+units

¥ ~ mu var 'r units

residual arlv (column) .arl(row)

PREDICT var !TWOSTAGEWEIGHTS W

Search Results | B[00 50

Ln 23, Cal10 Inzert Sel Normal Dos File size: 532

¢ Press the keyboard F9 key to run the command file.

This will display your job progress in the lower Output Console and also produce a number of
graphs.

> Executing: D:\ConTEXT W ConTEXT\ConExec.exe "C:\Program Files\ASReml4\bin\ASReml.exe” "barley.as™ ~

ASRem| 4,1 [28 Dec 2014] mv [29 Mov 2017] 24 Aug 2013 11:40:29
Registered to: wsn
Serial Mumber; 402061938, expiry: 31-mar-2013
ASReml 4.1 [28 Dec 2014] Slate Hall example
Build mv [29 Mov 2017] &4 bit Windows x&4
my [29 Mow 2017] 32 Mbyte barleyl

Univariate analysis of yield
Summary of 150 records retained of 150 read
Farming 26 equations: 26 dense,

Motice: Specify ISIGMAP to allow the Sigma parameterization
Predict Design Done
1 125 -739.68 36034,
LWAGR. b

| Output Conzole

Ln5, Col 26 Inzert Sel: Marmal Dos File zize: 592
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! Residuals vs fitted values _RvET1

Slate Hall example Residuals vs Fitted wvaluss RvEILL

Residuals (Y) -480: 537 Fitted wvalues (X) 1213: le74
a
a a
a
a
a a a a a
b a 2 : aa a 5
% a a a a a a
a - 9 a 1 q a a
L] a a H a a a a a
a - a H a a 1
a = a a _ | _ a8 a g a a a
a a a2 a a
| a
i a a a " a a
a £
a a a
a a . % a a
a a 95 a a a
a
a a a
a a8

! Variogram of arlv{column).arl{row)5n_11

Slate Hall example Sn_11
Variogram of arlwv(column).arl({row) 24 Rug 2018 11:40:29

COuter displacement Inner displacement

ASReml produces a number of output files resulting from the analysis including the following:

v/ Results summary file (.asr)
v Solutions to the mixed model equations effects (.sIn)

v If requested, predictions for some factors in the model (.pvs)
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¢ To view the output files, from the menu select File>Open then navigate to the ASReml
Projects folder on your desktop.
If you cannot see the full list of files click the dropdown list on the bottom right of the window and
select Text files.

& Open *
4+ » ThisPC » Desktop * ASReml Projects v O Search ASReml Projects pel
Organise Mew folder =~ [ @
A i A
s Quick access ] MName Date modified Type
barley.apj 26/02/2015 12:25 ASReml.AP).2
[ Desktop D R
' barley.as 17/02/2015 16:50 ASReml progrz
OneDrive - VSN International | )
& OneDrive rematiena M barley.asd 17/02/201516:50  ASReml data fi
Attachments [7] barley.ask 12/09/20180%:47  ASK File
Camtasia Studio D barley1 ash 12/09/2018 047 File
Docs_dont throw away D barleyl.aov 12/06/2018 09:47 AOQV File
Docurmnents [1¥M barley1.asr 12/09/201809:47  ASReml result
e AT .
Help and Manual D barleyl.msv 12/09/2018 09:47 MBSV File
_ M barley1.pvs 12/00/201208:47  ASReml predic
HelpAndManual Projects
M barleyl.res 12/00/201808:47  ASReml supple
J Ceoh :
& Jane Cohen [ barleyt.rsv 12/09/201809:47 RSV File
E This PC M barleyl.sin 12/09/201809:47  ASReml effect: y,
_J 30 Objects v < >
File name: | barley1.asr v| |Te1rlfi|5 ("o, * ) V|
| Open | | Cancel |
o Select the results summary file barleyl.asr then click Open.
Open and view other files in the same manner.
€ ConTEXT - [CAUsers\jane\Desktop\ASRem| Projects\barley.asr] — [m| X
€ File Edit View Format Project Tools Options Window Help -8 X
LPHAST| &S| $D0Ove | 008 EH %8 88 8 Tufis <
. barley. az . barleyl. asr
File Panel = Lo B0 w18 L 0 L 25 30 W . 40 45 6D L 85 L DL BS 0L 75 L E0 S
‘ File Explarer |F.a-.-.-.nh3.s. Histary ASReml 4.1 [28 Dec 2014] Slate Hall example ~
Build mv [29 Howv 2017] €4 kit Windows x64
SRR 12 Sep 2018 10:23:24.712 32 Mbyte barleyl
.barle}l].asr Licensed to: vsn 31l-mar—-201%
PN by s N -
* Contact support@asreml.co.uk for licensing and support ®
R
Folder: C:\Users\jans\Desktop\ASReml Projects
QUALIFIERS: !SKIP 1
QUALIFIER: !DOPART 1 is active
Eeading barley.asd FEREE FCRMAT skipping 1 lines
Univariate analysis of yield
Summary of 150 records retained of 150 read
Model term Size #miss #zero MinNon0Q Mean MaxNonO StndDevn
1 Rep & 0 0 1 3.5000 &
2 RoWBLk 30 0 0 1 15.5000 30
3 ColBlk 30 0 0 1 15.5000 30
4 row 10 0 0 1 5.5000 10
5 column 15 0 0 1 £.0000 15
& variety 25 0 0 1 13.0000 25
7 yield Variate 0 o0 917.0 1470. 2118 232.3 v
4 >« >
= Executing: C:\Program Files\ConTEXT\ConExec. exe "C:\Program Files\A5Reml4\bin\ASReml.exe” barley.as™ -
ASReml 4.1 [28 Dec 2014] mv [29 Nov 2017] 12 Sep 2018 10:23:24
Registered to: vsn
Serial Mumber: 402061998, expiry: 31-mar-2019
ASR_E!'nI 4.1 [28 Dec 20}4] Sla_te Hall E_xample W
x
Ln 37, Col 33 Ingert Sel: Nomal Dos File size: 3376
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Running ASRem|
The following are the basic steps for creating and running your own ASReml files.

1. Create a command file (-as) to run in ConTEXT.
You can do this by opening a data file in ConTEXT (.csv, -txt, .dat, -tabandsoon)
and pressing the F9 key to generate a template command file (.-as).

2. From the menu select File>Open then open the command file you created.
The created file is only a template, and you will need to edit it to ensure it reads the data
correctly and fits the model you want fitted.

3. After you've edited the command file, press the keyboard F9 key to run it. This will produce a
graph of the residuals and any other graphs you requested.

4. View the resulting output files by navigating to the same folder that holds the command file.

Notes

In step 2, instead of using File>Open, you can use the ConTEXT File Explorer panel to open files.

With a command file (or any other file) open, clicking the third button | takes you to your working
folder where you can immediately select any other files. (Note that you cannot view graphics or binary
files in ConTEXT; some graphics files can be viewed in Windows Explorer, or by inserting into a Word

document).

€ ConTEXT - [C:\Users\jane\Desktop! ASReml Projects\barley.as] - O *
€ File Edit View Format Project Tools Options Window Help -8 X
3 I & B 83 %8 8 8 8y AsReml -

L The ConTEXT File Expl
e .on lle EXplorer
File Panel P 0 2% . 3 . 3% . 40 . 45 . BD . BB . ED
(I T T ) A Y
File Explorer | 'BENAME 'REG 1 2 3 ~

E:'\“\iane'\Desktﬁp\&SHeml Frojects 1D9PAP‘T fl_ L

TE | 3 | = # Balanced incor
S5late Hall example

Mame
. Bep €
barley.a -
‘-1 ¥- 3Pl RowBlk 30
' barley. az -
ColBlk 30
' barley. azd row 10
| | barley.ask column 15
|| barleyl ash variety 25
| | barleyl. o yield
' barley1. asr barley.asd !'skip 1
| | barleyl.mey
' barleyl.pvs IPART 1 # RAR1*4RI
M barleyl.res " ¥ o~ I Var N
£ > £ >
| Ln 17, Col 4 Inzert Sel: Mormal Dos File zize: 532
i
on the

In step 3, instead of using F9, you can also run ASReml by clicking the first ‘head’ icon
ConTEXT toolbar. You will have set this association up when you configured the settings in
Options>Environment Options. Hovering the cursor over this icon will display the ‘hint’ ASRem|

(F9).

on - [C\Users\jane\Deskto eml Projects\barley.as -
€ ConTEXT - [C:\Users\jane\Desktop! ASReml Projects\barley.as] | *
€ File Edit View Format Project Tools Options Window Help -8 X
- F & 18 28 G W8] §: 8 Gy AsRem -
' barley. as
E—— x W5 .10 .15 . o0 . aReml P 4 45 om0 .55 L 6D
T O T T T T O O O O T T
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Setting up the Keyword Highlighter File

ASReml comes with a highlighter file (ASReml .chl) that ConText uses to highlight ASReml| keywords
when editing an ASReml command file.

¢ If you want to make use of this feature, copy the file
C:\Program Files\ASRemI\Context\ASReml .chl

to
C:\Program Files\Context\Highlighters.

When you open a command file (.as) the keywords will be highlighted in an assortment of colours,
which you can change to suit your requirements.

€ ConTEXT - [C:\Users\jane\DesktophASReml Projects\barley.as] - O =

€ File Edit View Format Project Tools Options Window Help -8 X
UPHATSB«DOva |2 A5 E % 8 & & 8 Ak -
’ barley. as

File Panel - .5 @ .15 .2 . 25 .30 . 3 .40 . 45 . 5 . 5 . 60 . 65 . 70 . 75 . 80 . 85

I||||I||||I||||I||||II\|\I\|I||I||||I||I||I||||I||I||I||||I||I|\I\|I||I||||I||I||I||||I||I||I

IRENAME 'ZRG 1 2 3 M
IDOPART $1

Bk $ Barly

’ barley. as

| File Explarer | Favarites

Histary

13 rial with 25 wvarieties in & r
incomplete block design.

example

Rep &
RowBlk 30
ColBlk 30
row 10
column 15
wvariety 25
yield
barley.asd !skip 1

'PART 1
¥ ~ mu var

residual arlv(column) .arl (row)
PREDICT var !TWOSTAGEWEIGHTS

# BAR1*ARL

'PART 2
¥ ~ ma var !r unitcs

residual arlv(column).arl(row)

PREDICT var !TWOSTAGEWEIGHTS W

# RR1*ARl+units

Search Results [NE AR |

Ln 23, Cal10 Inzert Sel Mormal Dos File size: 592

Changing the Highlighter Colours

e If you want to change the default colours, start ConTEXT then navigate to the ASReml
Projects folder on your desktop and open one of the example .as files so you can preview
your changes.

e From the menu select Options>Environment Options.

C ConTEXT
File View Project Toolsletions Window Help
@ Environment Options... ||__|j [j ) o }'_':- 'C_F- ﬁﬁ Iﬁ "3-%.
Fil Code Templates.., ”
r S, Stay On Top
O Export Registry Settings...
B2 2 -

o Click the Colors tab to see which options you can change.
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e Click an item in the list to see a preview in the Sample text panel.

e Make changes as required then click Apply to to see how the colours look in the .as file you
opened.

Environment Options >

General Editor  Colors | Execute Keps  Associations  Miscellaneous

Highlighter: [ PxA5Reml

D ezcrption:

Comment Eoreground: m -

Current Line

[dentifier Back o -
Eemaords 1 Ackgrne G
k.ewaords 2 [ ]1Bold
Kepwards 3 .
Kepwords 4 [ talic
Keywords 5 [ Underline

b atched braces
Hurnber
Preprocessar Sample text
Right edge
Selection
Space
String
Symbaol

Highlight current line

[ ] Oweride foreground test colors

[] Block autgindent
Block begin: |:|

Aoy Cancel
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Troubleshooting Known Issues

Backspace key does not work when editing a file

This problem appeared in Windows 10. When ConTEXT is open, BACKSPACE is focused on the
ConTEXT File Explorer panel rather than the text panel.

e Click in the File Explorer panel then click the third button |- | to reset the working folder.

¢ Now go back to the text window. BACKSPACE should now work as expected.

€ ConTEXT - [C:\Users\jane\Desktop\ASReml Projectsibarley.as] - O *
C File Edit View Format Project Tools Options Window Help -8 X
2 I & A S8 s 888 8y | ASReml -

B ooty The ConTEXT File Expl
e Lon lle EXplorer
File Panel P 20 25 . 30 . 3/ .40 . 45 . BD =]
T T T T T O O T T T T T T I
File Explarer | 'RENAME !ARG 1L 2 3 "~
C:A*jane\Desktoph\aSHeml Projects !DE)P‘B‘IFT 51 o B
# Barly trial with 25 warieties in 6 replicates laid out as
T:'g o ? = # Balanced incomplete block desi
Mame Slate Hall example
T - Rep &
barley,
u v-aR RowBlk 30
’ barley. as o
ColBlk 30
’ harley. azd cow 10
IJ_ barley. ask ool 15
|J. barleyl ash variety 25
| | barleyl.aov vield
’_ barleyl. ast barley.asd !skip 1
| | barleyl.mav
M baileylpes IPART 1 # RRI*RRI1
M barleyt e ¥ o~ ma Var 4
< £ >
| Ln 17, Col 4 Ihsert Sel Mormal pos File gize; 532
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File extensions are not visible in the File Explorer panel
This is a Windows® Explorer setting that affects ConTEXT.

e Open Windows Explorer and select the View tab.

| = | C\Users\jane\Desktop\ASReml Projects — O ot
Home Share View - o
I:| T Extra largeicons  [&] Large icons =)l [W] Item check boxes 7
Medium-sized icons Small icons - E File name extensions
Mavigation , = - —| ||Curren Hide selected Options
paie, & BB st == Details T view~ ¥ Hidden fems items 7
Panes Layout Show/hide
f# Videos M barley.as 17/02/2015 18:50 ASRe
I;ﬂ;'l1 wsnadmin (liz-pc) ’ barley.asd 17/02/2015 16:50 ASRe
5 05(C) [ barley.ask 12/09/201810:23  ASK|
. Data (D) D barleyl ash 12/00/2018 10:23 File
& barleyl., 12/09/2018 10:23 AV
2 DVD RW Drive (E) ] barley1.aov e "
’ barley1.asr 12/09/2018 10:23 ASRe
GenStat (WJANE-PC) (Z:
= GenStat (W 1) [ barleyl.msv 12/09/201810:23  MSV
m Libraries M barley 1 pys 12/09/201810:23  ASRe
¥ Network M barleylres 12/00/2018 10:23 ASRe
Control Panel barleyl.rsv 12/09/2018 10:23 RSV I
ey
la] Recycle Bin ’ barley1.sln 12/09/2018 10:23 ASRe
ASReml Projects [ barleyltmp 12/09/201810:23  TMP +
v o< >
89 items =5 =

e Select the File name extensions option.

o If ConTEXT is already open, close it then open again.
You should now be able to see all file extensions as expected.
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